Jump to content

Audi A7 multiple warnings


huesey1974
 Share

Recommended Posts

Hi,

I have an A7 BiTdi 2015, for a few weeks i had multiple dash warnings coming on intermittently, ABS, TPMS etc. it then became constant, however today my wife started it and had brake warning come up and do not drive, also the power steering went heavy and rear spoiler fault. I had a new battery fitted so definitely not that, Any ideas please? 

Link to comment
Share on other sites


9 hours ago, Magnet said:

Thanks Derek,

Was the alternator output checked? Was the new battery coded to the car? Make of new battery as a matter of interest?

Kind regards,

Gareth.,

Hi,

the battery was Lion I believe and is the correct spec, it was also coded to the car. Don’t think the alternator output was checked though. Im not at home so car is with my wife, not sure if its safe to drive to a garage with all this going on.

thanks

Link to comment
Share on other sites

Many thanks Derek,

Um! Alternator output would have been good, as would a check for any parasitic drain, but it would not have been out of the ordinary to simply replace the battery.

Lion batteries? From experience, Lion would be at the top of my ‘last brand to buy list’. 
Kind regards,

Gareth. 

Link to comment
Share on other sites

6 hours ago, Magnet said:

Many thanks Derek,

Um! Alternator output would have been good, as would a check for any parasitic drain, but it would not have been out of the ordinary to simply replace the battery.

Lion batteries? From experience, Lion would be at the top of my ‘last brand to buy list’. 
Kind regards,

Gareth. 

Hi,

I told my wife to check the battery installed, turns out it’s not Lion it’s possibly something worse, she says it looks like powermax which i have never heard of. Obviously if i was home I wouldn’t have accepted this and would have been Bosch, Exide or Varta. Not her fault i suppose, anyway its an AGM with the correct specs. Im now wondering if i should get a better brand and try that. She did say she started it today and it was just the ususl faults but the Brake Warning please stop safely/ spoiler malfunction had disappeared and the power steering was ok. Had similar on BMW and it was wheel sensor or battery. The garage i use and trust is closed till the 6th☹️

Link to comment
Share on other sites

1 hour ago, huesey1974 said:

Hi,

I told my wife to check the battery installed, turns out it’s not Lion it’s possibly something worse, she says it looks like powermax which i have never heard of. Obviously if i was home I wouldn’t have accepted this and would have been Bosch, Exide or Varta. Not her fault i suppose, anyway its an AGM with the correct specs. Im now wondering if i should get a better brand and try that. She did say she started it today and it was just the ususl faults but the Brake Warning please stop safely/ spoiler malfunction had disappeared and the power steering was ok. Had similar on BMW and it was wheel sensor or battery. The garage i use and trust is closed till the 6th☹️

Let me know what you get I have the same just appeared on mine but goes off intermittently. Mechanic changed brake cable a couple of months ago as kept stating new brakes required when he had changed them due to a a wiring fault so think it may be something to do with the wiring

Link to comment
Share on other sites

Let me know what you get I have the same just appeared on mine but goes off intermittently. Mechanic changed brake cable a couple of months ago as kept stating new brakes required when he had changed them due to a a wiring fault so think it may be something to do with the wiring

Link to comment
Share on other sites

30 minutes ago, Ghc said:

Let me know what you get I have the same just appeared on mine but goes off intermittently. Mechanic changed brake cable a couple of months ago as kept stating new brakes required when he had changed them due to a a wiring fault so think it may be something to do with the wiring

Hi,

mine was also intermittent but then became permanent, last few days got worse though as stated. Will keep you updated. 

Link to comment
Share on other sites

  • 2 weeks later...
On 12/30/2022 at 5:52 PM, huesey1974 said:

Hi,

mine was also intermittent but then became permanent, last few days got worse though as stated. Will keep you updated. 

Did you find out what was wrong. 

Link to comment
Share on other sites

Posted (edited)

Hi,

The car is currently with my mechanic , he has told me it needs a new ABS sensor/ wheel bearing. Hopefully this fixes it and will update when i find out.

thanks

Edited by huesey1974
Link to comment
Share on other sites

Did you get it resolved my GPS has currently gone now as well, showing im 100s of miles away. My garage has said they're waiting for the electrician to come back next week and he will be able to diagnose apparently satnav is common fault and requires the internal roof lining to be removed to access the from on the roof where the GPS is. 

Link to comment
Share on other sites

23 minutes ago, Ghc said:

Did you get it resolved my GPS has currently gone now as well, showing im 100s of miles away. My garage has said they're waiting for the electrician to come back next week and he will be able to diagnose apparently satnav is common fault and requires the internal roof lining to be removed to access the from on the roof where the GPS is. 

Hi,

still not got it back, waiting on ABS wiring loom as it had water ingress. I will update when i do though.

thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership