Jump to content

2006 A4 Convertible remote roof operation module weirdness


gsmdo
 Share

Recommended Posts

Hi there,

I had a remote roof module fitted in my A4 about six years ago and it worked fine. Recently it started playing up - specifically it wouldn't open the hood remotely. I thought six years was fair for a cheapish after-market gadget, so ordered another one to replace it - this one:

https://www.ebay.co.uk/itm/143424315368

464370870_ModuleOne.thumb.jpg.be6cd13b009b50d3955e6fc357786e7d.jpg

Β 

2133306463_ModuleTwo.thumb.jpg.ff4eed4b7978ee8c8fa7452330417548.jpg

I removed the door card to fit it and, since it was similar in appearance to the defective unit, and had identically coloured wires, I just cut the old unit off and, using crimp connectors, joined like to like.

Before I put the door card back on, I tested it. Nothing - not a sausage.πŸ€¦β€β™‚οΈ

I put the car away for the night, having also discovered that I had bought the wrong size door card clips. 🀨

The following morning, I came out to the garage with a mate of mine to explain the snag. Before we took anything apart, I tried the unit again (you press 'lock' three times within five seconds to raise the roof; 'unlock' three times within five seconds to lower it) - bingo - it worked perfectly πŸ˜ƒπŸ‘

My mate (an RAF Techie on the F35 LIghtning) just said "Ferking canbus - there's no understanding it" πŸ˜† He reckoned the canbus does a system check during down time and finds and adopts new stuff. This might not be accurate, but certainly follows the early snags I had with the original module, which was a nightmare for 24hrs - and then worked perfectly... πŸ€”

Fast-forward two weeks and it has become unreliable. Normally when you press the remote for the third time you'll get a 'click-click' noise from the car, and then it'll enter its routine. Today I've been unable to raise or lower the roof remotely (although the button on the centre console still operates normally, as does holding the key in the locked or unlocked position in the driver's door to raise or lower the roof).

Anybody have any ideas on what might be causing this, or how to persuade it back to normal operation please?

I'm going to drop the vendor a line with a link to this post, although my feeling is that it's not a fault in the module - more likely another canbus interface thing.

I recognise that this is likely the ultimate first world problem πŸ˜† but any advice/experience would be appreciated.

Thanks,

Mike 😎

Β 

Β 

Link to comment
Share on other sites


Well the vendor has been brilliant πŸ˜ƒ. Here's the response from him first thing this morning:

Hello

I found out what is the issue.

You have a rare version of software in door ECU and this is actually making a mess.

It happened only twice so far for a few hundred modules already sold.

Today morning I posted a compatble version of the remote control module that will solve the issue.

Tracking available atΒ 
XXXX

We stay in touch.

Regards

I don't think you can ask for better service than that 😎 The vendor is based in Poland, so from experience it'll take a week or so to get here. It'll be ten minutes work to fit it (now that I have the right door clips - and some sparesπŸ˜†).

My car is a 'facelift' 2006, which I have found differs from its predecessor and successor in some weird waysΒ  - like keeping the relays under the ECU, for example - so this may be another anomalous example of that.

I'l post the result once it's been fitted.

Cheers,

Mike😎

Β 

Β 

Β 

Link to comment
Share on other sites

10 minutes ago, gsmdo said:

Well the vendor has been brilliant πŸ˜ƒ. Here's the response from him first thing this morning:

Hello

I found out what is the issue.

You have a rare version of software in door ECU and this is actually making a mess.

It happened only twice so far for a few hundred modules already sold.

Today morning I posted a compatble version of the remote control module that will solve the issue.

Tracking available atΒ 
XXXX

We stay in touch.

Regards

I don't think you can ask for better service than that 😎 The vendor is based in Poland, so from experience it'll take a week or so to get here. It'll be ten minutes work to fit it (now that I have the right door clips - and some sparesπŸ˜†).

My car is a 'facelift' 2006, which I have found differs from its predecessor and successor in some weird waysΒ  - like keeping the relays under the ECU, for example - so this may be another anomalous example of that.

I'l post the result once it's been fitted.

Cheers,

Mike😎

Β 

Β 

Β 

That's great news. Hopefully once the new one is fitted it'll resolve the issue 🀞

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




Γ—
Γ—
  • Create New...

Forums


News


Membership