Rigy

Keyless entry and start

Recommended Posts

Hi guys

I recently bought my Q7 3.0TDI s-line. It came with Keyless entry and start however, neither seem to work. I spoke to my dealer and I've been told that even though the buttons are in the car it doesn't have those functions. Quite frankly I don't believe them, I've looked around at others  and if they don't have it they don't have the buttons either. My guess is there is a problem with it. I've replaced my key fob battery with a new one but made no odds. 

I've searched the net for answers but found nothing, does anyone have a clue where I start? 

 

Cheers

 

Rigy

Share this post


Link to post
Share on other sites
 
4 hours ago, Rigy said:

It came with Keyless entry and start

if it does not have the functions why put it in the car makes no sense, most things not in a car extras are just blanked off. i think you need a 2nd opinion m8

Share this post


Link to post
Share on other sites

Yeah I agree, I think it does have it and it's not working, anyone any ideas on testing if I have it or not or how to get it working if it is broken? 

Share this post


Link to post
Share on other sites

Pressing the button does nothing at all, no message saying key not present or anything like that. Keyless entry I'm not that fussed about to keyless start I really want as I'm used to it from my previous car... 

Share this post


Link to post
Share on other sites

i think your best bet is to call Audi give them your reg and they will know for sure whats fitted on your car

Share this post


Link to post
Share on other sites
3 minutes ago, Paul A6 said:

i think your best bet is to call Audi give them your reg and they will know for sure whats fitted on your car

That's a good idea, will let you know what they say... 

Share this post


Link to post
Share on other sites

Ok, i called into Audi today and asked the question about the keyless start. I was told by a sales man that he couldnt bring up my spec due to the age of my car. He said that keyless start didn't come to the q7 until 2011 however, they put the buttons in.

I didn't bother to argue with him, however, i know that's not the case as i test drove 2 cars prior to mine that each had it and they were older than mine. Now another thing just occurred to me, 2 days after i bought my car i managed to lock the keys in it (long story) a lock smith came out and let me in. in a conversation with him i asked could the plastic key start my car, he informed me that it could as it has a chip in it, however, when he tried it it didn't, he put the key in a reader and said yes it definitely should start it and my car must of had a new set of keys at some point.

I am now thinking perhaps that's the problem, is anyone on here any knowledge regarding keys, programming, and keyless start?

 

cheers

Rob

Share this post


Link to post
Share on other sites

Would Audi give you a proper clue, don't ask the sales lad as my 56 plate is keyless! Do you doors. Unlock if you are close by? Is there a black rubber square in the door handle?

Share this post


Link to post
Share on other sites

I'm hoping to pop in today and grab a tech, yes doors have the square but doesn't work, I believe it's the key, the fact neither works would suggest that I'd say. There is an independent VW Audi garage the my dealer knows he's going in today to see what they can do... Anybody know how easy programming keyless start is? 

 

Cheers

 

Rob

Share this post


Link to post
Share on other sites

Did you get a solution to this. I'm having same problem on an 09 q7 4.2tdi I just bought. 

Share this post


Link to post
Share on other sites
6 hours ago, Newbrook82 said:

Did you get a solution to this. I'm having same problem on an 09 q7 4.2tdi I just bought. 

Yeah i did mate, transponder in the passenger rear door, if you fine a really quiet spot and press your keystart button or better still get someone else to do it and sit next to the door you will hear the relay clicking. Change that transponder and it will all work again...

Share this post


Link to post
Share on other sites
On 1/4/2019 at 2:35 PM, Rigy said:

Yeah i did mate, transponder in the passenger rear door, if you fine a really quiet spot and press your keystart button or better still get someone else to do it and sit next to the door you will hear the relay clicking. Change that transponder and it will all work again...

Hello Rob,

Is there a Transponder in the rear door ?

Can you specify the component you replaced ?

 

Thanks,

Jose

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...