Jump to content

Air suspension fault


Recommended Posts

Hello everyone, i have purchased an Audi a6 allroad 2.5, i got the car very cheap but as you would expect it has its problems, i have worked my way through quite a few of these but i seem to have hit a wall on the information side. The problem i am facing is the air suspension, the pump will not turn at all, i have removed the pump and just as the man said from whom i bought it from, the pump has been overhauled, i have proved the pump with a direct feed, it works fine with plenty of compression, however when i connect it back to the cars electrics i get nothing, i have bought a new relay as i have been told that this is more than likely the culprit, now here is the part where i have hit the wall, i can't find a single photo of the location of this relay, i was hoping that someone has a photo showing where it goes, then i can eliminate the relay and move on to the next suspect, hope someone can help, thank you for reading my post 

Link to comment
Share on other sites

3 hours ago, Steve Q said:

Has the system been checked for leaks? Both the bags and pipes can leak. 

I can't test it because it wont pump it up past the control box mate, i was wondering if i could use my garage compressor to test for leaks to each unit from the control block

Link to comment
Share on other sites

5 hours ago, johnkarl said:

Thank you , will give it a go with my garage compressor and check for leaks

No probs. Sorry I can't help much. I know c5s but not allroad suspension unfortunately. Guessing you've tried the fuses when you tried the relay? 

Link to comment
Share on other sites

yes mate all fuses checked, just had my friend over with his ridiculous priced Snap-On diagnostic and it says that the suspension ECU has no communication, so i am assuming that this is the cause of the problem, looks a bit of a faf to get it out,  but we will see

Link to comment
Share on other sites

On 6/11/2021 at 1:32 PM, johnkarl said:

yes mate all fuses checked, just had my friend over with his ridiculous priced Snap-On diagnostic and it says that the suspension ECU has no communication, so i am assuming that this is the cause of the problem, looks a bit of a faf to get it out,  but we will see

Where is that ECU located? 

Link to comment
Share on other sites

On my A6 2001 allroad, the suspension module is located in the rear passenger side, if in the UK, forward from the multi cd player, you can just say see the side of it, looks a pig to get at

Link to comment
Share on other sites

8 hours ago, johnkarl said:

On my A6 2001 allroad, the suspension module is located in the rear passenger side, if in the UK, forward from the multi cd player, you can just say see the side of it, looks a pig to get at

I ask as I was going to say if it had been the driverside or on the bulkhead then it could have got damaged by getting wet from blocked drains on battery tray. Or the washer pipe coming free on the driverside. But as it's passenger side that blows my theory. Might be worth trying to source a second hand unit. I believe you'll need one with the same part number I suspect. 

Link to comment
Share on other sites

  • 2 weeks later...

Ihave gone down a different road to test the air bags for leaks, i have cut the pipes from the air control valve [ red,black,blue and green ] and i have fitted shrider valves to each individual pipe, i have then pumped up the suspension to the highest point on each air bag, i have then done the soapy water test and could not see any bubbles indicating a leak anywhere, they have all been up now for 3 days with no sign of any drooping from any corner, once i am satisfied that the air bags are fine [ two weeks should do it ] i will then drop it down to a more manageable Hight, no rush at all, still have not located the position of the suspension pump relay, this is an ongoing problem, cant find a photo or video for my uk car anywhere

Link to comment
Share on other sites

I have seen this photo and seen the video

thanks, however my relay board is totally different to this one, thanks for helping mate, much appreciate your time looking for the suspension relay, but this is not the same as mine, you would have thought with the number of written advice on the problems this relay has caused, some one would have posted a picture of it, but my search goes on, thanks again

 

Link to comment
Share on other sites

8 hours ago, johnkarl said:

I have seen this photo and seen the video

thanks, however my relay board is totally different to this one, thanks for helping mate, much appreciate your time looking for the suspension relay, but this is not the same as mine, you would have thought with the number of written advice on the problems this relay has caused, some one would have posted a picture of it, but my search goes on, thanks again

 

You're welcome, sorry it was wrong. Just can't think where else it could be. 

Link to comment
Share on other sites

  • 4 months later...
On 6/8/2021 at 5:05 PM, johnkarl said:

Hello everyone, i have purchased an Audi a6 allroad 2.5, i got the car very cheap but as you would expect it has its problems, i have worked my way through quite a few of these but i seem to have hit a wall on the information side. The problem i am facing is the air suspension, the pump will not turn at all, i have removed the pump and just as the man said from whom i bought it from, the pump has been overhauled, i have proved the pump with a direct feed, it works fine with plenty of compression, however when i connect it back to the cars electrics i get nothing, i have bought a new relay as i have been told that this is more than likely the culprit, now here is the part where i have hit the wall, i can't find a single photo of the location of this relay, i was hoping that someone has a photo showing where it goes, then i can eliminate the relay and move on to the next suspect, hope someone can help, thank you for reading my post 

I had this model Allroad many years ago (10 or so). I think! That the relay sits in the fuse panel behind the drivers side dash, up behind the steering wheel, there’s also a 40A fuse that they recommend changing, the wiring diagram should show that. (Haynes?)

But I’d try asking an VW or Audi dealer (you might have to go in, they’ve told me before that they won’t answer technical queries over the phone, something to do with legal liability if you then get hurt or damage the car!)

Or, best option, find a non franchised specialist.

I’ll check but don’t think I have the Haynes manual any more.

 

good luck

Dave 

Link to comment
Share on other sites

On 6/8/2021 at 5:05 PM, johnkarl said:

Hello everyone, i have purchased an Audi a6 allroad 2.5, i got the car very cheap but as you would expect it has its problems, i have worked my way through quite a few of these but i seem to have hit a wall on the information side. The problem i am facing is the air suspension, the pump will not turn at all, i have removed the pump and just as the man said from whom i bought it from, the pump has been overhauled, i have proved the pump with a direct feed, it works fine with plenty of compression, however when i connect it back to the cars electrics i get nothing, i have bought a new relay as i have been told that this is more than likely the culprit, now here is the part where i have hit the wall, i can't find a single photo of the location of this relay, i was hoping that someone has a photo showing where it goes, then i can eliminate the relay and move on to the next suspect, hope someone can help, thank you for reading my post 

Found this on another Audi site:-

just got the car back from the dealer. After lots of investigation and 1.5hrs shop rate, it turns out there is a 40 amp fuse under the hood behind a relay box The fuse protects the compressor motor. It took a few calls with Audi dealer tech support for the mechanic to find the fuse. Apparently when the old compressor prssure switch failed, and the pump ran without kicking off due to over temp, the fuse blew???

 

Link to comment
Share on other sites

On 6/8/2021 at 5:05 PM, johnkarl said:

Hello everyone, i have purchased an Audi a6 allroad 2.5, i got the car very cheap but as you would expect it has its problems, i have worked my way through quite a few of these but i seem to have hit a wall on the information side. The problem i am facing is the air suspension, the pump will not turn at all, i have removed the pump and just as the man said from whom i bought it from, the pump has been overhauled, i have proved the pump with a direct feed, it works fine with plenty of compression, however when i connect it back to the cars electrics i get nothing, i have bought a new relay as i have been told that this is more than likely the culprit, now here is the part where i have hit the wall, i can't find a single photo of the location of this relay, i was hoping that someone has a photo showing where it goes, then i can eliminate the relay and move on to the next suspect, hope someone can help, thank you for reading my post 

This might help locate relay & fuse:- Fuse/relay panel diagrams and key.

https://fuseandrelay.com/audi/allroad.html

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Forums


News


Membership