Jump to content

What kind of miles should i be getting audi a4 b7 2.0 tdi 140


 Share

Recommended Posts


58 minutes ago, Beany1 said:

Getting around 100 miles on 20 pound diesel is that about right on city driving 

Yes I'd say that's right. All depends on what fuel you're using. Ie shell costs a lot more than Tesco for example. 

Link to comment
Share on other sites

Hello Beany,

If you are buying your diesel at £1.70 a litre ( that’s really cheap Steve - close on, and above £1.80 here)  then you are buying 2.6 gallons for your £20. If so, your mpg works out at about 38.5 mpg. If your diesel costs you more, then you are obviously getting a better mpg than that. 
Kind regards,

Gareth. 

 

Link to comment
Share on other sites

Yes its cheap in costco 1.70 a litre im getting around 100 miles with 20 pound diesel on trip computer says 37.4 mpg dont know if thats ok 

Link to comment
Share on other sites

7 hours ago, Beany1 said:

Yes its cheap in costco 1.70 a litre im getting around 100 miles with 20 pound diesel on trip computer says 37.4 mpg dont know if thats ok 

It's fine. My daily only gets 34mpg.  And the Audi far less than that on short journeys. 

Link to comment
Share on other sites

My car vibrates and shakes when engine temp get warm around 70 to 90 degrees when engine cold its smooth what could be problem 

Link to comment
Share on other sites

You can feel the car shaking and you can feel it through seats but idle is not bouncing about the needle is steady 

Link to comment
Share on other sites

Steve Y should be able to make more valid suggestions, but might include possible injector problems?? 
Kind regards,

Gareth.

Link to comment
Share on other sites

Could be an injector, cam sensor. I'd advise a diagnostic check. Did you change the engine mounts as discussed in your other thread? 

Link to comment
Share on other sites

I've changed the snub mount and the driver side mount steve but not changed the driver side yet with sensor on it could mounts be problem only vibrates when engine warms up not on cold engine 

Link to comment
Share on other sites

1 hour ago, Beany1 said:

Will any injector cleaner help with injectors something like millers diesel eco or something

Yep try injector cleaner. And a diagnostic check. Could be a cam sensor. 

Link to comment
Share on other sites

9 hours ago, Beany1 said:

Is it easy to change and do you know where its located 

Hi if its not missing and the revs are stable it is most likely the mount you have not yet changed, camshaft position sensors are very reasonable as its an older model and they are a pretty easy fit.

The reasoning behind the engine mount theory is if you think about it when the engine is cold the oil in the mount is cold, therefore when the engine warms up so does the oil in the Hydro mount which makes the oil thinner, as Steve said get it checked for codes and have a look at the old mount to see if its spat its oil out.

Steve.

Link to comment
Share on other sites

Ye makes sense did have a look at the passenger side mount the one with sensor does look like its got a little crack does it mean when it gets hot the oil gets thin and gives more vibration and yes there is no problem on the revs its stable just under 1k is it good idea to check if my snub mount is centered and not touching the snub mount cradle will that cause vibration too thanks 

Link to comment
Share on other sites

The snub mount should be centred in the shroud as it doesn't bear weight. It's there to limit vertical movement.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...

Forums


News


Membership